New Freerunner - never gets GPS fix

Andy Green andy at
Thu Jul 31 22:37:42 CEST 2008

Hash: SHA1

Somebody in the thread at some point said:
| Mike Doody wrote:
|> Hi,
|> My new Freerunner has never gotten a GPS fix. I have tried the latest
|> kernel (from 7/29) and also tried getting a fix with the SD card
|> removed and waited an hour.
|> I've tried agps-gui and tangoGPS, I've made sure that the NMEA
|> sequences were being received. But never a fix.
|> Is there anything I can do - check signal levels or something - or do
|> I need to return this for warranty replacement?
| did you change the parameters  for the gpsd  (/etc/defaults/gpsd) ?
| I think that you should change the device file to /dev/ttySAC1 .
| after that restart the service and check it without the SD card.

Along those same lines, if there is some question about app config you
can look at the raw NMEA in a shell and get an idea pretty well.

echo 0 > /sys/class/i2c-adapter/i2c-0/0-0073/neo1973-pm-gps.0/pwron &&
sleep 1s && echo 1 >
/sys/class/i2c-adapter/i2c-0/0-0073/neo1973-pm-gps.0/pwron && stty -F
/dev/ttySAC1 -echo && cat -u /dev/ttySAC1 | grep -v ^$

- -Andy
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Fedora -


More information about the support mailing list