[FSO] ETK and GTK python apps cause "Segmentation fault"

Søren Kristiansen sorenhk at gmail.com
Wed Nov 12 22:46:44 CET 2008


I'm working on a small python app for my freerunner. The app runs smoothly
without any graphical user interface but when I use either ETK or GTK it
causes a segmentation fault. I've tried to run each of the example scripts
at http://wiki.openmoko.org/wiki/Python .

When using ETK:
[Etk-Warning] (ecore_evas_x11.c:190 - _engine_init()):
Ecore_X initialization failed!

[Etk-Warning] (etk_engine.c:221 - etk_engine_load()):
Etk can not initialize the requested engine!

Segmentation fault

When using GTK (note python-pygtk wasn't installed so I had to install it
with opkg):
/usr/lib/python2.5/site-packages/gtk-2.0/gtk/__init__.py:69: GtkWarning:
could not open display
  warnings.warn(str(e), _gtk.Warning)
Segmentation fault

And some more details:
opkg update && upgrade doesn't fix the issue. I've tried reflashing the
image too. 

Thanks in advance for your help :)
View this message in context: http://n2.nabble.com/-FSO--ETK-and-GTK-python-apps-cause-%22Segmentation-fault%22-tp1491701p1491701.html
Sent from the Openmoko Support mailing list archive at Nabble.com.

More information about the support mailing list