Problems Flashing the Neo Freerunner

bravas gigartua at
Sat Nov 22 23:37:26 CET 2008

Hi, I bought a few days ago a Neo FreeRunner and wanted to switch to version
I have read these guides 

But when it started,pressing boot either on the menu NOR or NAND Always get
the error:

mage Name:Openmoko/2.6.24+git75969+a1e97c6
Created: 2008.-11-05
Image Type: ARM Linux Kernel Image (uncompressed)
Data Size:1894648 Bytes = 1.8 MB
Load Address:30008000
Entry Point:30008000
Verifying Checksum ... Bad Data CRC
Can't get Kernel image

I have installed with mandriva linux,and transfers of kernel,rootfs or
u-boot always end up with the correct message

state(2) = dfuIDLE, status(0) = No error condition is present

the steps of the guides mentioned above ,always end well,I have completed
the steps that are necessary, but it fails when  boot.

Download the images from here 

I have also tried to boot from the SD and gives me the same error.
After 4 days of testing with images of openmoko, and Qtopia,always say the
same when booting

Verifying Checksum ... Bad Data CRC
Can't get Kernel image

I also tested with different u-boot downloaded from here  
But I get the same error :(

The truth that the first time I started Flashing the Neo Freerunner,I
execute a command following in the steps of that other guide 

dfu-util -a 0 -R -D Om2008.9-gta02-20081106.uImage.bin

I think that I should not have run
Is the only command that I executed it should not have done it.

I posted my problem here 


View this message in context:
Sent from the Openmoko Support mailing list archive at

More information about the support mailing list