New battery semi-charged but not charging, is protection-circuit broken?

Michael Shiloh michael at
Mon Sep 1 18:14:29 CEST 2008

ankostis wrote:
> On Mon, Sep 1, 2008 at 6:28 AM, Michael Shiloh <michael at> wrote:
>> Did you update u-boot and kernel? There was a bug awhile back causing
>> USB insertions to be only partially recognized.
> I have not updated UBoot and i cannot do it anymore since the battery
> has fallen significantly making it impossible to enter into USB ACM.
> I've used kernel from 2008.8 and FSO (2 days ago), nothing too recently.
> I thinki i've seen the bug you mention,
> when it requires to insert the USB twice in order to enter 'Charging" status.
> But yet, no real current flows into the battery and the battery's
> reported capacity remains 0.
> Yesterday, the current_now started to show some non-zero values, but
> judging from the voltage_now,
> the battery did not actually charge.
> Michael, I would really like to know if there is any possibility of
> reviving the battery or if i should definitely contact the reseller
> for a new one,
> since i live in a different country from the reseller it and it will
> take some time to receive a new battery.

If you're feeling adventurous, try to revive the battery using Joerg's 
unofficial instructions [1], then update u-boot and kernel, then see if 
charging works better.

If you're not feeling adventurous, ask your reseller for a new battery, 
and if it works, then return the old one as faulty.



More information about the support mailing list