Undefined USB Device

Matt Mets matt.mets at cibomahto.com
Tue Sep 2 01:38:31 CEST 2008

On my T61 laptop, it appears that the bluetooth adapter is identified by 
dfu-util as a target.  I worked around it by turning off the bluetooth 


Joachim Ott wrote:
> 2008/9/1 Michael Fisher <desnotes at gmail.com <mailto:desnotes at gmail.com>>
>     When attempting to flash my FreeRunner from a Thinkpad Laptop with
>     Ubuntu 7.10 installed, I get two USB devices after plugging in the
>     FreeRunner and running dfu-util -l. I did have a USB mouse
>     attached but I removed it and rebooted but I still get the same
>     message. Even after rebooting with no USB devices connected and
>     running dfu-util -l, I receive the response that one Undefined
>     device is connected.
>     Is there a way to specify which USB device is to be upgraded with
>     dfu-util or is there a way to clear out all references to USB devices?
> Do this in the following order:
> 1) put the Neo into NOR boot menu, i.e. press and hold AUX, then press 
> Power button
> 2) after that connect the USB cable
> 3) on the Thinkpad as root: run "dfu-util -l" , and when the Neo is 
> found, flash it
> ------------------------------------------------------------------------
> _______________________________________________
> support mailing list
> support at lists.openmoko.org
> https://lists.openmoko.org/mailman/listinfo/support

More information about the support mailing list