using openocd

Lynn Nguyen lynn.mesl at
Tue Sep 2 04:47:49 CEST 2008

I tried the sequence but still the same errors.

Should I have a /dev/ttyUSB1 when I plug in the debug board? because i


On Mon, Sep 1, 2008 at 5:03 PM, Mike Montour <mail at> wrote:

> Lynn Nguyen wrote:
> >     An easily made but devastating mistake is to forget to actually
> >     activate the CPU. Just connecting power is not enough ! Press and
> >     hold the power button until the boot loader does its count-down, or,
> >     in case there is no runnable boot loader, the CPU keeps itself busy.
> >
> > is the 'it' this part referring to the openmoko? I mean, isn't the whole
> > point of a bricked openmoko the fact that it can't turn on? How am I
> > supposed to activate the CPU if it won't turn on at all? I know the
> > battery is fully charged because I checked the voltage.
> "it" does refer to the phone. "Turn it on" means setting the
> power-management unit (PMU) into Active mode so that voltage is applied
> to the CPU. This might happen automatically when you plug in the USB
> cable, but if not you can do it by pressing the power button. If the
> device is "bricked" you will not see anything happen when you turn it
> on, but internally the CPU will be ready to accept a JTAG connection.
> Try following the sequence described at
> (which
> AFAIK should be the same for a v3 debug board).
> > this is the openocd.cfg i am using:
> Looks OK to me.
> _______________________________________________
> support mailing list
> support at
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the support mailing list