Can bad NAND blocks cause USB's "device descriptor read/64, error -110" ?

sledge simaskonfa at
Wed Sep 3 01:22:15 CEST 2008

Hello dear all,

My new FR (DateCode 20080725) is suspected to having bad NAND blocks:
It had been suffering kernel panics etc. after as soon as I reflashed it
with Om2008.8 on 20080831. Subsequent reflashings rendered my FR less

I'm still suffering with USB cdc_ether, I'm getting `device descriptor
read/64, error -110' and no solution found out there on the net helps.

Last time tried with:
u-boot,rootfs (20080902) -- from Openmoko_update page
kernel (20080902, too) -- from daily page.
(!)With the 20080826 kernel from releases/_update page says wrong image
format whatsoever.. (and still does if I try to revert to the 20080826 one)

Tried everything I could google, no cure:
* I have usbnet, cdc_ether compiled as modules. uhci_hcd, too, -- modprobe
-r uhci_hcd (re-insert) does not help;
 - /dev/ttyACM0 gets created OK, from NAND and from NOR
* I use the USB cable supplied in my packaging, even tried the other one.
* Could not try out,
because I don't know where to get the u-boot'er any more fresh than I have
(1.3.2, Aug 26)

Thanks for helping pushing this through towards an initially-usable FR; and
keep up the great good work, lads!

View this message in context:
Sent from the Openmoko Support mailing list archive at

More information about the support mailing list