GPS device missing in debian

Chris Jenks chris at
Thu Sep 4 00:00:06 CEST 2008

On Wed, 3 Sep 2008, Joachim Breitner wrote:

> Hi,
> Am Mittwoch, den 03.09.2008, 12:14 -0700 schrieb Chris Jenks:
>> I understand that the GPS device is accessed through
>> /dev/s3c2410_serial1 in debian rather than through /dev/ttySAC1 as under
>> 2008.8 (BTW, GPS under 2008.8 worked for me). However, I'm not getting any
>> s3c2410_serial1 appearing in my /dev, and my debian is up to date, with
>> kernel 2.6.24. All that dmesg says about s3c2410_serial1 is:
>> s3c2440-uart.1: s3c2410_serial1 at MMIO 0x50004000 (irq = 73) is a S3C2440
>> I couldn't find a module to load. I know other people have this working in
>> debian, but I thought I followed the wiki closely. Any suggestions?
> Did you install Debian via the installer? This should have installed a
> udev rule that renames the serial device to the usual /dev/ttySAC1. If
> that?s the case, where did you find the information about the device
> name /dev/s3c2410_serial1?
> Thanks,
> Joachim

I installed using the script at
and, after turning on GPS, tried cat /dev/ttySAC1 but this just returns to 
the prompt without showing any data. Then I found the /dev/s3c2410_serial1 
mentioned at but now I 
realize that page is obsolete (relative to the first).



More information about the support mailing list