2008.8 updated today and illume as default profile brings "classical" enlightenment

François TOURDE fr-om at tourde.org
Thu Sep 4 17:31:54 CEST 2008


Le 14126ième jour après Epoch,
Thomas B. écrivait:

> On Thu, Sep 04, 2008 at 08:53:46AM +0200, Olivier Berger wrote:
>> Hi.
>> I updated to today's stable packages (after noticing quite a lot of merges
>> from testing), and lost the illume/raster keyboard.
>> I tried to apply the hacks described at
>> http://wiki.openmoko.org/wiki/Keyboard_Debate#How_to_install_the_illume_.28Raster.27s.29_keyboard_.3F
>> (more or less), and noticed that now, only the 'asu' default profile
>> seems to bring the 2008.8 theme, and setting it as 'illum' (echo
>> 'E_PROFILE="-profile illume"' > /etc/enlightenment/default_profile)
>> will switch to "classical" enlightenment "desktop like" theme, menus,
>> etc.
> I also had this issue when I upgraded today.

Me too, like others I imagine ;)

>> I think the http://wiki.openmoko.org/wiki/Keyboard_Debate should be
>> updated, but I'm not so sure something ain't broken in the current
>> stable updates :-/
> Yes, I think there is actually something broken. When I did "opkg files
> illume-config-illume" after the upgrade, it showed that this package was
> actually empty, just like several of the other illume packages
> (illume-keyboard-*). Doing an "opkg install" with the URL of the
> packages in the testing feed didn't seem to work either, I had to
> download the ipk's from the testing feed, put their md5sums into the
> packages list in /var/lib/opkg/daily-all and "opkg install *.ipk". That
> did it for me.

I do a

opkg -force-depends purge illume-<strange packet>
opkg install illume-<strange packet>

for each packets, then modified /etc/enlightenment/default_profile and
finally restarted X. Everything is correct now.


More information about the support mailing list