getting error while trying to flash my neo freerunner

Michael Shiloh michael at
Fri Sep 5 01:57:49 CEST 2008

Detructor wrote:
> Am Donnerstag, den 04.09.2008, 12:47 -0700 schrieb Michael Shiloh:
>> Detructor wrote:
>>> Am Donnerstag, den 04.09.2008, 12:32 -0700 schrieb Michael Shiloh:
>>>> Detructor wrote:
>>>>> Am Donnerstag, den 04.09.2008, 11:11 -0700 schrieb Michael Shiloh:
>>>>>> Detructor wrote:
>>>>>>> I've used the command out of the wiki...for example
>>>>>>> "sudo ./dfu-util -a rootfs -R -D ./Om2008.8-gta02-20080904.rootfs.jffs2"
>>>>>>> I'm using the standard terminal from gnome
>>>>>>>         Hey guys,
>>>>>>>         I hope you can help me, I've the following problem:
>>>>>>>         When I try to flash the neo on my laptop I get a
>>>>>>>         "Starting download: [dfu_download error -71"
>>>>>>>         sometimes the download starts and then I get the error.
>>>>>>>         When I get the neo in June, I could flash it without getting this error.
>>>>>>>         My operating system: Ubuntu 8.04.1
>>>>>>>         I ask here, because I can't find anything about this error in the www
>>>>>>>         (only 3 entries in google and none of it helps).
>>>>>>>         hope for help
>>>>>>>         Detructor
>>>>>>>         ======================
>>>>>>>         Hi,
>>>>>>>         What command line did you use? One cause of this error is when you give 
>>>>>>>         the wrong argument to dfu-util, e.g. -a u-boot while flashing a kernel 
>>>>>>>         image.
>>>>>>>         Michael
>>>>>> And is your u-boot a recent version? Although if it's not it will be 
>>>>>> hard to update until we solve this problem.
>>>>>> Does this problem persist for kernel and u-boot too?
>>>>>> Can you check the integrity of the image you're trying to flash with md5sum?
>>>>>> Michael
>>>>>> _______________________________________________
>>>>>> support mailing list
>>>>>> support at
>>>>> -> yep for kernel, too. but with some luck I got the kernel flashed (I
>>>>> tried it 20 times, than it was flashed ;))
>>>>> -> nope I never flashed u-boot and yep it is the correct image (md5 is
>>>>> correct) 
>>>> This could be the cause of your trouble. Your u-boot may be quite out of 
>>>> date.
>>>> By the way, have you tried flashing with the NOR u-boot? If that works, 
>>>> I would recommend you right away flash a new u-boot into NAND, then use 
>>>> that new u-boot to flash your kernel and rootfs.
>>>> _______________________________________________
>>>> support mailing list
>>>> support at
>>> Hi,
>>> I've tried just 10 seconds ago to flash u-boot via NAND...after three
>>> tries, the 4th get it on the phone...after that, I choosed "power off"
>>> and restarted the phone...back in NAND, I tried to flash the rootfs
>>> again...but, there was the same error.
>>> I don't know why this error occurs, but 2 weeks before, I've flashed the
>>> freerunner several times without that problem...
>>> errhm, before you ask: the u-boot version that I've flashed is from
>>> here:
>> Try to flash the NAND u-boot while using the u-boot in NOR. IIRC this 
>> was prefereable for some reason.
>> M
>> _______________________________________________
>> support mailing list
>> support at
> same result...

Ouch. I'm out of ideas.

We need help from someone more expert with dfu-util than I. Let me see 
what I can find.

We might also ask on the kernel list and on the IRC channel.

Finally, we can take a look in the dfu-util source and see what reasons 
are for error -71.

More information about the support mailing list