SD Card Issues On GTA02

Marzak jonevalencia at
Fri Sep 5 20:36:05 CEST 2008


I just purchased my FreeRunner and I have run into a couple of issues
dealing with the SD card.  I researched and attempted a lot of
troubleshooting and am not sure where to go from here.  Here is what I have
tried so far:

Initially I tried to install qtopia to the SD card to try out that
interface.  I followed the instructions for the install and moved over the
rootfs.  When I tried to decompress the tar, I received an "invalid tar
magic" error.  I tried a couple more times and continued to receive that

I removed the SD card and accessed it from my linux host and was able to
complete the qtopia installation with no errors.  I placed the SD card back
in the FreeRunner and was able to boot qtopia off the SD card with no
issues.  It seemed stable and I had no running issues.

I then decided to try debian and downloaded it's installer.  I ran the
installer and received the same "invalid tar magic" error during the debian
stage.  I rebooted and attempted again several times with the same result. 
It did not always happen in the same place, but it was the same error.

I upgraded uBoot to gta02v5 and the kernel and rootfs to the latest
Om2008.8.  I tried the debian installer again with the same results.

I tried both running the installer again right after a failure and I tried
rebooting and then running the installer again.  Still the same results.  A
couple of times the unit locked up when I attempted to run the installer
again directly after a failure.

I read the information about slowing down the clock speed to allow for
slower cards.  This is the original SD card, but I gave it a try anyway.  I
created another boot menu entry with the added argument to max the speed at
10000000.  I tried the debian installer again and had the same error.

I checked over the list of supported SD cards and tried a 2GB scandisk
thinking that maybe my SD card had an issue.  Same results.

Is there anything that I missed or did not consider? Anything else I can
try?  Could I have a bad SD controller?


View this message in context:
Sent from the Openmoko Support mailing list archive at

More information about the support mailing list