Mike Montour mail at
Sun Sep 14 19:14:24 CEST 2008

Armin ranjbar wrote:

> so i did connected my device to minicom , i thought that there might be
> something wrong with nand memory , i did 'erase all' and 'nand erase' ,
> then i have tried 'reset' which cause device to hang ( white screen of
> death! ) 

If you ran "nand erase" without specifying a partition (e.g. "nand erase 
rootfs") then you have wiped out the NAND copy of u-boot and its 
environment partition. You should be able to recover it using the NOR 
copy of u-boot. I haven't tried this yet, but I would do something like:

- Boot from NOR u-boot (hold Aux then hold Power)
- Use dfu-util to download a new copy of u-boot into NAND ("dfu-util -R 
-a u-boot ...")
- Power off
- Reboot into NAND u-boot (hold Power then hold Aux)
- Use the "dynpart", "dynenv set u-boot_env", and "saveenv" commands to 
set up the NAND partition table
- Re-create the u-boot environment variables such as menu entries
- Re-flash your kernel, rootfs, and splash-screen partitions with dfu-util

The page 
may be of interest, even though it doesn't apply directly to your situation.

You may also want to use the "neocon" terminal program instead of 
minicom, since "neocon" has a per-character delay option that allows you 
to copy+paste long strings into the u-boot console.

More information about the support mailing list