[2008.8+] Audio issues.

Al Johnson openmoko at mazikeen.demon.co.uk
Mon Sep 15 17:19:26 CEST 2008

On Monday 15 September 2008, Matt wrote:
> My  2.5mm 4 ring - 3.5 3 ring adapter has arrived, and keen as mustard,
> I tried it out using mplayer and my normal headphones.
> To my dismay sound only came out of one earphone, it's not he first
> adapter I have tried either; I have a growing collection of adapters.
> However, while I was lamenting the recent purchase, I twiddled the
> connection with the FR and both earphones started working.  I don't mean
> working as in half-pulling-the-adapter-out-mono nonsense, but working
> stereo (at least I think so).
> Why might this be, the adapter plug is not bent or disfigured?
> Also, how do I configure the FR speak to mute when the headphones are
> attached?

Which image are you running? 2008.8 didn't change alsa states on headset 
insertion last time I checked, which would lead to output in only one ear. 
I've not checked FSO or Qtopia. I think it worked with 2007.2 but I'm not 
certain. Try enabling the headset.state manually:

alsactl -f /usr/share/openmoko/scenarios/headset.state restore

More information about the support mailing list