[2008.8+] Audio issues.

Al Johnson openmoko at mazikeen.demon.co.uk
Mon Sep 15 19:16:52 CEST 2008

On Monday 15 September 2008, Daniel Benoy wrote:
> What will it take to implement this?  I presume there's some kind of
> insertion signal?

It appears on one of the event interfaces - /dev/input/event0 IIRC but it 
could easily be one of the others. What needs doing will again depend on the 
distribution, and it's complicated by the fact that every app that does alsa 
state switching needt to know about it.

According to [1] the latest oeventsd does the switching, but it's not clear of 
zhone picks the right scenarios when making phone calls. It looks like 
everything the apps need should be available in the dbus APIs though, so I 
suspect FSO will soon get support for both wired and bluetooth headsets.

2008.8 doesn't switch anything when the headset is inserted, and the dialler 
app seems equally unaware of headsets, wired or wireless. Given the mixture 
of qtopia and non-qtopia bits I don't know what the best way forward would be 

I think 2007.2 worked with the wired headset but I wouldn't swear to it, and 
don't have it installed to try it out.

[1] http://wiki.openmoko.org/index.php?title=OpenmokoFramework/Status_Update_4

> On Monday 15 September 2008 11:19:26 Al Johnson wrote:
> > On Monday 15 September 2008, Matt wrote:
> > > My  2.5mm 4 ring - 3.5 3 ring adapter has arrived, and keen as mustard,
> > > I tried it out using mplayer and my normal headphones.
> > >
> > > To my dismay sound only came out of one earphone, it's not he first
> > > adapter I have tried either; I have a growing collection of adapters.
> > > However, while I was lamenting the recent purchase, I twiddled the
> > > connection with the FR and both earphones started working.  I don't
> > > mean working as in half-pulling-the-adapter-out-mono nonsense, but
> > > working stereo (at least I think so).
> > >
> > > Why might this be, the adapter plug is not bent or disfigured?
> > > Also, how do I configure the FR speak to mute when the headphones are
> > > attached?
> >
> > Which image are you running? 2008.8 didn't change alsa states on headset
> > insertion last time I checked, which would lead to output in only one
> > ear. I've not checked FSO or Qtopia. I think it worked with 2007.2 but
> > I'm not certain. Try enabling the headset.state manually:
> >
> > alsactl -f /usr/share/openmoko/scenarios/headset.state restore
> >
> > _______________________________________________
> > support mailing list
> > support at lists.openmoko.org
> > https://lists.openmoko.org/mailman/listinfo/support

More information about the support mailing list