2008.08 "Illegal instruction" after opkg upgrade

Roman Pszonczenko xtensa at gmail.com
Fri Sep 19 21:39:45 CEST 2008

Hi, I just tried to make opkg upgrade. In the middle of upgrade opkg
hanged. I pressed Ctrl+C and nothing works from that moment. Every
single command returns "Illegal instruction" message. Ok, fine, it
means that sth was compiled with the instruction that CPU does not
provide. I rebooted to qtopia then and tried to make chroot to my
2008.08. Again illegal instruction. Further investigation showed that
libc and ld libraries are broken. When I replaced everything in /lib
directory I can chroot to 2008.08, but only basic things are
working... I mean there are another libraries/programs that are
compiled with these unsupported instructions.

I also noticed few days ago while compiling personal project, that
arm-angstrom-linux-gnueabi-g++ compiller tries to use rorl and rorw
thumbs. In that case I also got "illegal instructions" message because
of these thumbs. As far as I know S3C2442B cpu shoud support Thumbs
Extension and it is not OS dependant. Does it means that thumbs are
"turned off" on my FreeRunner somehow??

Just to be clear from where I am upgrading:

root at om-gta02 /etc/opkg $ cat *
src/gz daily-Multiverse http://downloads.openmoko.org/repository/Multiverse
src/gz daily-all http://downloads.openmoko.org/repository/Om2008.8/all
arch base 50
src/gz base http://www.angstrom-distribution.org/feeds/2008/ipk/glibc/armv4t/base
arch all 1
arch any 6
arch noarch 11
arch arm 16
arch armv4t 21
arch fic-gta02 26
arch neo1973 31
arch om-gta02 36
src/gz daily-armv4t http://downloads.openmoko.org/repository/Om2008.8/armv4t
#src/gz daily-neo1973 http://downloads.openmoko.org/repository/Om2008.8/neo1973
src/gz daily-om-gta02 http://downloads.openmoko.org/repository/Om2008.8/om-gta02


More information about the support mailing list