neo1973 does not power on.

Michael Shiloh michael at
Tue Sep 23 18:32:46 CEST 2008

tck6346 at wrote:
> After a recent reboot, the system never came back. Pushing the power button
> causes nothing to happen. I don't even seem to get into uboot(no logo screen). I
> don't have a debug board. I do not have a sim card. I've been running Debian off
> of the SD card mostly with success. I reflashed Uboot a few weeks ago, but have
> rebooted many times since then without incident.
> most recent changes (prior to last reboot):
> 1) I added the onboard fs to my fstab in my SD debian install so that I could
> access it while booted into debian.
> 2)I changed from the debian server over to the Xfbdev server copied from
> the onboard fs. It worked fine when I did a startx. And I know it was running
> the Xfbdev server because I was able to screen rotates with xrandr.
> Things I've tried:
> 1) I tried pulling the battery, to clear state. Then restarting.
> 2) Letting it sit plugged in to make sure the battery had good charge. I
> measured 4.1 volts across the battery terminals(out of the phone).
> 3) I removed the SD card. and repeated the above steps.
> Any suggestions as to what to try next?

I would guess the internal state machine is locked up in a bad state, 
and the only way out is to drain the internal backup battery in order to 
reset this state machine.

How long did you leave it without power and without battery? You need to 
leave it long enough for the internal backup battery to drain. I'm not 
sure how long this is, but overnight seems to work.

Perhaps someone with more intimate knowledge of the backup battery can 
provide more details.


More information about the support mailing list