enlightenment crashes

Robin Paulson robin.paulson at gmail.com
Fri Sep 26 11:24:35 CEST 2008

2008/9/26 The Rasterman Carsten Haitzler <raster at rasterman.com>:
> perhaps doing what it suggests might help? :) note - chances are whatever you
> have  is likely behind the curve and possibly is segving as a result of
> inconsistent packages (eg svnrev of illume != svnrev of efl/e-wm). most likely.

i flashed the new 2008.9 image a few days ago (i'd done an opkg
upgrade from 2008.8, but had been having the same problems, so went
from scratch and re-flashed), and have got the stock feeds - no extra
repos or anything, and i've done an opkg update && upgrade every day.
it's up to date now and still giving that message, so i doubt
anything's out of sync

> so first check illume and evas, e-wm, edje, ecore, eet, embro, efreet, edbus
> are all the same svnrev. what svnrev is that? also installing -dbg (debug)

ok, i did a check - all those packages (guess you mean embryo, not
embro?) are svnr 35818, with varying suffixes - r1/r2/r3/r4/r6/r12

> packages for these and gdb and gdb attaching and getting a backtrace will mean
> i can actually help you! :)

right, installed the -dbg packages, and lots of dependencies too...

i'm afraid the rest is beyond me - i read up a bit on gdb and
backtraces, but got lost around the use of file. any hints would be
great, or do you have a script ready-built that i could use?

cheers for the help, appreciated

More information about the support mailing list