No GSM. Suspect dead Calypso. What to do?

danek daniel at
Fri Apr 10 03:57:33 CEST 2009

Hi support list,

I posted previously about my problem on this list, and have not made any progress in my situation despite many repeated attempts at getting my modem to work. I tried everything I could think of, and when that didn't work, many people on the list had helpful suggestions, which I also tried to no avail. To recap briefly from my previous posts:

- I started using the FreeRunner when I got it in August '08. I started using it as my daily phone pretty much right away, suffering for a while, before I got things working more or less the way I wanted them to.
- In early December, it suddenly stopped working. I hadn't changed anything on the phone for several days before it stopped working. One minute I was making and receiving calls, and the next I couldn't dial out, and people couldn't reach me. I rebooted and it still didn't work. I switched my SIM to my dumbphone so I could look at the problem later when I got home.
- I got home and reflashed my kernel and rootfs. No change. I tried several different combinations of kernel and rootfs, all of which worked fine with my phone and SIM before. I knew the SIM was fine, because it worked with my dumbphone. I tried some other SIMs anyway, which also were known to work with my phone before the GSM stopped working. Nothing. It was a busy week for me so I put the Neo down and kept using my dumbphone for a little while.
- A couple of weeks later I contacted the list for suggestions. Someone suggested looking at the output of logread, which showed a "+CME ERROR: 100" when trying to talk to the modem. Setting a PIN was also recommended; the phone prompted me for a PIN, meaning it was able to see my SIM, even though it couldn't register the network. It also rejected incorrect PIN entries and accepted correct ones, further demonstrating that the SIM was recognized.
- Somebody also suggested flashing moko10. I did this, and the update took fine, but did nothing for my problem.
- Elsewhere on the list, I read a tip about logging into the USB console to fix a broken u-boot environment. About a month or two before the GSM stopped working, my u-boot environment broke and I could only successfully boot from the NOR u-boot, not the NAND. I was able to successfully fix u-boot and boot from NAND once again, but my GSM was still broken.
- I noticed that there was a beta moko11 firmware. In desperation, I flashed this. The update went fine, but still no GSM.
- I have continued trying different images and SIMs and other things, hoping the phone would magically come back to life, but no luck.

I can still use the FR for non-phone stuff (GPS still works like a champ), but would REALLY like to get GSM working again sometime soon. At this point I am convinced that something broke in the hardware somehow, and would like to know what I can do about getting the unit repaired and what the associated costs would be.
View this message in context:
Sent from the Openmoko Support mailing list archive at

More information about the support mailing list