No GSM. Suspect dead Calypso. What to do?

danek daniel at
Sat Apr 11 05:17:17 CEST 2009


Thanks for the tip. I just got home and tried this, and it worked much better than the methods I had tried before for talking to Calypso manually (cu would hang and not accept any AT commands IIRC), but unfortunately I was still unable to register. Of course I was using 2007.2 (or 2008.4, depending on what you call it) because the instructions I found were ancient.

I did as you said:

1. Stop anything using the /dev/TTYSAC0 -- I was using Om2008.12, so as far as I knew, this was just qpe. I did killall qpe, then when the error popped up on the Neo screen I told it not to relaunch. Then, for good measure, I stopped xserver-nodm too.

2. Power cycle the GSM modem.

3. socat ... this was not installed by default. I managed to find the package at, but it depended on libssl 0.9.8 and libcrypto 0.9.8. I couldn't find packages for either. Opkg update; opkg upgrade did nothing. I noticed that I had version 0.9.7 of both, and figured that talking to the Calypso shouldn't involve any kind of encryption anyway, so I decided to do an ugly hack and symlink the 0.9.7 SOs to 0.9.8 so I could install socat. I just now realized that I probably didn't have / couldn't get 0.9.8 because I installed stable, and should probably switch to testing or something else, so that I can try this again as intended. I'll do that after I send this message and report back (not expecting much to happen).

4. Since it took a while to get socat sorted, and I wasn't sure what you meant when you said Calypso goes to sleep "very fast" (goes to sleep after being powered on? in between commands? didn't know.) I figured it would be a good idea to power cycle the modem again.

5. OK, now we run socat with the parameters you gave:

Neo: AT-Command Interpreter ready
Me: ATE1
Neo: //nothing ...
Me: ATE1
Neo: ATE1
Neo: AT+CFUN=1 // pause for a couple of seconds
// at this point, i don't know what has gone wrong, so I keep giving commands anyway...
Me: AT+CPIN="4747" // i don't normally use a SIM pin, but i do like the number 47, so I set this SIM pin on my dumbphone. When I enter it when QPE asks me, it's happy. When I enter something else, it's not. So I'm assuming the Neo is working correctly with the PIN.
Neo: AT+CPIN="4747"

AT-Command Interpreter ready
//It looks like it reset itself. I try dialing anyway...
Me: ATD+1XXXYYYZZZZ // this is a US telephone number, phone sitting next to me
Neo: //hang...
//hang... i try ATH anyway
Neo: ATH
OK //phone doesn't ring

Since it gave me an error at AT+CFUN=1 before, I tried again, just pasting "AT+CFUN=1" over and over again, but it kept saying "ERROR", whatever that error is.

I didn't know what AT+CFUN=1 did, so I looked up Hardware:AT_Commands in the wiki and saw that AT+CFUN=1 sets the modem to phone mode. I saw that AT+CFUN? could be used to query what mode the modem was operating in, so I initialized the modem again and did AT?CFUN? and got +CFUN: 0

So if I understand what is happening correctly (and I might not, because this is my first time talking directly to a GSM device) it seems that the modem never goes into phone mode.

Is there anything else you would try at this point?

Thanks again,

View this message in context:
Sent from the Openmoko Support mailing list archive at

More information about the support mailing list