[debian] python broken; no input

arne anka openmoko at ginguppin.de
Wed Apr 15 20:33:53 CEST 2009

yesterday i rebooted the fr again after several weeks and it immediately  
turned out to be the wrong thing.

system is an up-to-date debain/unstable, most notably
- python2.5 2.5.4-1
- fso-frameworkd

Package: xserver-xorg
Version: 1:7.4+1
Package: xserver-xorg-core
Version: 2:1.6.0-1
Package: xserver-xorg-input-evdev
Version: 1:2.2.1-1
Package: xserver-xorg-input-kbd
Version: 1:1.3.2-3
Package: xserver-xorg-input-mouse
Version: 1:1.4.0-2
Package: xserver-xorg-input-tslib
Version: 0.0.5-8
Package: xserver-xorg-video-fbdev
Version: 1:0.4.0-4

a) python is mostly broken -- as far as i can see, every python apps  
missed modules and is unable to import them.
seems i can work around that by setting  
but i am not sure if i catch all cases with that -- and with the crucial  
role python plays on the fr, it is really a showstopper.

i hope, with all these snake charmers out there someone will come up with  
a viable solution or some hints, how to solve that.

b) still the frameworkd needs several seconds if not minutes to respond to  
what request ever, which makes zhone time out several times

c) i can't click buttons anymore. although the cursor moves with my stylus  
and jumps to where i tap -- buttons, checkboxes ... do not receive clicks  
and thus nothing is usable

atm the fr is unusable and since it is my sole phone, it is a bit urgent  
;-) -- so, any help is highly appreciated!

More information about the support mailing list