Audio Problems (Om2008.12)

Andrew Stone abs407 at
Sat Apr 18 00:04:26 CEST 2009

I just got my Sim Card into my Freerunner, and when I tried to place a call, I got no audio...whatsoever.   Opening up alsa (that was fun...), I adjusted everything around, and I could only get the bottom speakers on.   I changed some of the *.state files as suggested in the wiki and a few online posts (ie. I downloaded and tried them), and the same thing...only the bottom speakers would work -- no earpiece.

I adjusted the volume (during a call) with pymixer and alsa, and still nothing.

When I plug in my headphones, the audio is forwarded to them, and the volume/quality is just fine.   When I put it on speaker phone, the volume and quality there are just fine, too.   I only cannot get any sound out of the earpiece in the handset.

I booted into debian on the phone, and I used speaker-test to run noise through all of the speakers, and I could get audio, again, everywhere but the handset earpiece.

Could this just be a faulty speaker in the handset?

View this message in context:
Sent from the Openmoko Support mailing list archive at

More information about the support mailing list