Audio Problems (Om2008.12)

Joerg Reisenweber joerg at
Sat Apr 18 02:42:48 CEST 2009

Am Sa  18. April 2009 schrieb Andrew Stone:
> I just got my Sim Card into my Freerunner, and when I tried to place a call, 
I got no audio...whatsoever.   Opening up alsa (that was fun...), I adjusted 
everything around, and I could only get the bottom speakers on.   I changed 
some of the *.state files as suggested in the wiki and a few online posts 
(ie. I downloaded and tried them), and the same thing...only the bottom 
speakers would work -- no earpiece.
> I adjusted the volume (during a call) with pymixer and alsa, and still 
> When I plug in my headphones, the audio is forwarded to them, and the 
volume/quality is just fine.   When I put it on speaker phone, the volume and 
quality there are just fine, too.   I only cannot get any sound out of the 
earpiece in the handset.
> I booted into debian on the phone, and I used speaker-test to run noise 
through all of the speakers, and I could get audio, again, everywhere but the 
handset earpiece.
> Could this just be a faulty speaker in the handset?

might be a possible cause. Anyway adjusting all the mixer controls the right 
way is rather difficult. 

So I'd ask you to do the following

ssh in to FR
establish a call
from ssh console execute
alsactl -f /usr/share/openmoko/scenarios/gsmhandset.state restore

please make sure you haven't edited gsmhandset.state. Check if sound from 
earpiece speaker starts working.

You also might want to check with another distri, like FSO e.g.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: This is a digitally signed message part.
Url : 

More information about the support mailing list