GTK and FR

Iurii yuri at
Tue Dec 8 09:21:03 CET 2009

i'm going on with my development from the time i received My FR
basicly the first thing ive done i have tried to write the "Hello word" with
GTK it looks fine

secondly i have tried to write on the FR my application written before.
i dont like to deal with changing the kernel i prefer the stable one from
the factory 
so my application is based on gtk+ 
to actually run it on my old device i was using an image which is called
gumstix-x11-32mb-image and constists from next Recipe:

    xserver-kdrive-fbdev \
    ttf-dejavu-sans \
    ttf-dejavu-sans-mono \
    matchbox \
    matchbox-panel-hacks \
    xcursor-transparent-theme \
    rxvt-unicode \
    gpe-terminal \
    matchbox-keyboard \
    gpe-theme-clearlooks \
    xst \
    xhost \
    xrdb \
    gpe-dm \
    gpe-login \
    gpe-session-scripts \
    gpe-icons \
    gpe-confd \
    gpe-autostarter \
    ${@base_contains("MACHINE_FEATURES", "touchscreen", "libgtkstylus",
"",d)} \
    ${@base_contains("MACHINE_FEATURES", "keyboard", "", "libgtkinput",d)} \
    teleport \
    xauth \
    gdk-pixbuf-loader-png \
    gdk-pixbuf-loader-xpm \
    gdk-pixbuf-loader-jpeg \
    pango-module-basic-x \
    pango-module-basic-fc \
    matchbox-panel-manager \
    gpe-su \
    gpe-conf \
    gpe-package \
    gpe-taskmanager \
    keylaunch \
    minilite \
    minimix \
    xmonobut \
now when im trying to run my soft on the FR which is runnig with GTA-02 rev
i get the illegal instruction error 
i assume i need to add the packages wich i was using in my old image 
gdk-pixbuf-loader-png \
gdk-pixbuf-loader-xpm \
gdk-pixbuf-loader-jpeg \

i have them in the .ipk for armv5te can i install them? if yes how ?
when i do 
ipkg install 
it says me that there is no sush a command as ipkg
View this message in context:
Sent from the Openmoko Support mailing list archive at

More information about the support mailing list