GTK and FR

Al Johnson openmoko at
Tue Dec 8 13:11:57 CET 2009

On Tuesday 08 December 2009, Iurii wrote:
> i'm going on with my development from the time i received My FR
> basicly the first thing ive done i have tried to write the "Hello word"
>  with GTK it looks fine
> secondly i have tried to write on the FR my application written before.
> i dont like to deal with changing the kernel i prefer the stable one from
> the factory
> so my application is based on gtk+
> to actually run it on my old device i was using an image which is called
> gumstix-x11-32mb-image and constists from next Recipe:
[snip list of packages]
> now when im trying to run my soft on the FR which is runnig with GTA-02 rev
> 20081029
> i get the illegal instruction error
> i assume i need to add the packages wich i was using in my old image
> gdk-pixbuf-loader-png \
> gdk-pixbuf-loader-xpm \
> gdk-pixbuf-loader-jpeg \
> i have them in the .ipk for armv5te can i install them? if yes how ?

Yes and no. You can install .ipk packages (see below) but armv5te is the wrong 
instruction set. This is probably the reason for the illegal instruction 
error. You will need to recompile for armv4t to run it on the Freerunner.

> when i do
> ipkg install
> it says me that there is no sush a command as ipkg

opkg install packagename

More information about the support mailing list