[FSO] Wifi in M5 no longer functioning

Dylan Semler dylan.semler at gmail.com
Thu Feb 5 15:47:02 CET 2009

On Thu, Feb 5, 2009 at 5:56 AM, Al Johnson <openmoko at mazikeen.demon.co.uk>wrote:
> 'SetResourcePolicy WiFi enabled' tells FSO to power up the WiFi
> of whether any apps have issued 'RequestResource WiFi'. Before I do this I
> have no eth0 available.

Yeah, but it seems to also configure eth0 because after I SetResourcePolicy,
If I do ifup eth0 right away I get "ifup: interface eth0 already configured"

To get dhcp working I would often have to do:
> ifup eth0
> ifdown eth0
> ifup eth0

I know what you're talking about, I definitely had to do this with past
images as well.  However, with M5, there's still no luck with the second
ifup eth0.

> On the second ifup the association often completes a little quicker so dhcp
> has a chance of completing before timeout. Another method is to manually
> start
> dhcp after the first ifup using something like:
> udhcpc -i eth0
Yeah, this suffers the same fate is ifup, ifdown, ifup.  It's good to know
if I revert to an older image.

> This assumes wpa_supplicant is making the association fine. You can check
> that
> with wpa_cli which accepts a 'help' command to tell you what other options
> it
> has.
> This has worked for me on everything I've tried since 2007.2, but I've not
> tried it on the recent SHR or MS5 yet. SHR, and probably MS5, have the
> added
> complication of connman running. This tries to manage the network
> connections,
> but at least for usb0 it is overridden by the ifup and ifdown commands.
> Assuming connman actually works, the other option would be to use the
> connman
> dbus interface to set the network parameters. Don't ask me how though ;-)
I'll poke at this when I have more time after the weekend.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.openmoko.org/pipermail/support/attachments/20090205/796d8c72/attachment.htm 

More information about the support mailing list