FSO Milestone 5

Rod Whitby rod at whitby.id.au
Sat Feb 7 23:18:44 CET 2009

Rename checkroot.sh to just checkroot (remove the .sh).
This is an upstream OE bug which made it's way into FSO ms5 - it also affected nslu2-linux SlugOS images.
-- Rod

-----Original Message-----
From: Joel Newkirk <freerunner at newkirk.us>
Date: Sunday, Feb 8, 2009 8:18 am
Subject: Re: FSO Milestone 5
To: Support for Openmoko Device Owners <support at lists.openmoko.org>Reply-To: Support for Openmoko Device Owners <support at lists.openmoko.org>

If you manually invoke '/etc/init.d/checkroot.sh' once it's finished
>booting and is still read-only, it will correctly remount root to
>read/write...  This is the same checkroot.sh that is called early during startup yet apparently fails to remount / rw at that time.  If you insert the remount command near the top of checkroot.sh it WILL successfully remount during initial boot, so it IS executing checkroot.sh during
>startup, but something is different between then and the manual invocation from the terminal once booting has finished.  What??
>On Fri, 06 Feb 2009 21:22:51 -0500, Simon Comeau Martel <simon at comeau.info> wrote:
> You are right;
> / is in read-only mode when I boot from Qi. (and in rw mode when I boot
> from uBoot)
> The problem is not in 'checkroot.sh' itself; I compared that file from
> Milestone 5 to the one I had on a previous testing version which worked
> fine, and the file is exactly the same... Something must have change
> elsewhere.
> --
> Simon Comeau Martel
> simon at comeau.info
> https://comeau.info
> Joel Newkirk wrote:
>> On Fri, 06 Feb 2009 18:57:03 -0500, Simon Comeau Martel
> <simon at comeau.info>
>> wrote:
>>> I have no idea how it is possible.
>>> All I know is that if I boot Milestone 5 via Qi, get the following
>>> message in zhone:
>>> 	Usage: Requested ressource GSM with error.
>>> And the problem is reproducible; it happen every time.
>> Read-only filesystem.  Once you've booted and see the GSM error in
> Zhone,
>> open a terminal and try "touch test" - you'll get an error noting that
> the
>> rootfs is read-only.  Qi mounts rootfs read-only at the start - I
> believe
>> /etc/init.d/checkroot.sh is where it's supposed to be remounted
> read/write.
>> Many things will be 'broken' in this state, like you cannot SSH into it
>> because dropbear doesn't start properly when it can't write, and just
> about
>> everything with frameworkd is broken.
>> Presuming this is the case (I'm betting;) try
>> mount -o remount,rw /
>> /etc/init.d/frameworkd restart
>> stop Zhone, restart it, and it should be able to activate GSM...
>> I've not worked through the logic in /etc/init.d/checkroot.sh or
> anything
>> yet to see where this is failing, but putting the remount command at the
>> top of that script will restore your FR to usefulness, remounting / rw
>> fairly early in the boot process.  (checkroot.sh is supposed to

More information about the support mailing list