Qi causes WSOD (was Re: [2008.testing] WSOD)

Andy Green andy at openmoko.com
Tue Feb 24 07:22:08 CET 2009

Hash: SHA1

Somebody in the thread at some point said:
| On Feb 24, 2009 2:31am, Andy Green <andy at openmoko.com> wrote:
|  > Suspend and resume on 2.6.24 only works by luck, it's not telling us
| much.
| OK. You are saying that with uBoot+2.6.24, it wasn't suspending
| properly, hence resume worked, but with Qi+2.6.24, suspend worked, but
| resume is broken.

What I mean is that it's known 2.6.24 kernel stuff is broken for suspend
/ resume in a deep way, if it happens to work it's basically chance.  So
hearing that it doesn't work properly under some conditions don't give a
good clue, since it can break under different timing or interrupts or
whatever happening.  2.6.28+ stuff has this fixed, so misbehaviour on
resume means a smaller set of possibilities and we can start to imagine
what can be happening.

| Why does Qi/uBoot affect this?

I think it's to do with the sequencing of power / init to the LCM.  In
U-Boot, we bring up the Glamo and LCM to show the boot logo.  In Qi, we
do not bring up the Glamo LCD controller nor program the LCM until the
Linux drivers start.

We know that the guts of the LCM are not entirely under control since
the last WSOD business, there's some people reporting monochrome display
after resume as well.  But it varies by physical LCM, I run Qi for
months every build and I don't see any of it on my test GTA02.

| What distro do I need to flash to test this properly (i.e. which diistro
| is using 2.6.28 or 2.6.29)? FSO? I understand that I can't simply flash
| 2.6.29 onto 2008.12 as the userspace file structure is different.
| Which kernel is Debian using 2.6.24?

This FSO v5 thing, really anything with 2.6.28 should also work well
with 2.6.29 stuff.

- -Andy
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Fedora - http://enigmail.mozdev.org


More information about the support mailing list