Help! GSM not working after updating to Moko10

Nicolas Dufresne nicolas.dufresne at
Thu Feb 26 20:40:23 CET 2009

I heird recently that moko10-11 causes some timeout bug in older FSO
(it's also in firmware release notes). Have you validated using latest
FSO 5.1 millstone ?


-------- Message initial --------
De: M. K. Pkhetan <pkhetan at>
Reply-to: Support for Openmoko Device Owners
<support at>
À: support at
Sujet: Help! GSM not working after updating to Moko10
Date: Thu, 26 Feb 2009 21:55:47 +0300

Hi everybody,

I really appreciate your help because my phone is not any more a phone!!

the story is that i have updated the GSM firmware to the Moko10 in my GTA2Bv5 as described on

I have follow exactly the instructions there on the same proposed FSO, and every thing went ok, i even got the message :

(fluid, version 3) ok
Checksumming (269 * 8kB = 2152kB):  ok
Flash Detect: (0xEC, 0x22A0) Samsung K5A3240CT ok
Program: (34 sectors, 267*8k=2136k) (*******************) ok

so every thing seemed ok i even tried the proposed verification :

root at om-gta02:~# cat /dev/ttySAC0 &
root at om-gta02:~# echo -en 'AT\r' >/dev/ttySAC0
root at om-gta02:~# echo -en 'AT+CGMR\r' >/dev/ttySAC0
+CGMR: "HW: GTA, GSM: gsm_ac_gp_fd_pu_em_cph_ds_vc_cal_amd8_ts0-Moko10"
kill %1

Well, after that i went back to SHR testing, but i couldn't register to the GSM network. i tried FDOM and same thing : no registering

Then i said maybe the firmware is not valid (even that i ckecked the md5sum and it was ok) so i tried to downgrade to Moko8 (the gta02bv5 one) but i stucked in "Bootloader: (reset target)"

i tried the -oO and -oo. with and without the 'FLUID_FLOWCONTROL=h' and in the other season i tried the "s3c24xx-gpio b7=1", "echo 0 > /sys/bus/platform/devices/neo1973-pm-gsm.0/power_on" and "echo 1 > /sys/bus/platform/devices/neo1973-pm-gsm.0/power_on" but nothing work i can't reflash my GSM anymore

i really don't know what to do now.......


Lower Salmon River Rafting Trips
Professionally guided 4 & 5-Day family rafting adventures since 1979.

-------------- next part --------------
An HTML attachment was scrubbed...

More information about the support mailing list