GTA02 is now an expensive brick

Lucas Lacroix raijinsetsu at
Sun Jan 4 17:38:51 CET 2009

I forgot to plug the Neo in last night, and now the battery is completely
dead. I cannot even get to the NOR boot. I've tried both USB and the
charger. I have tried with and without the battery. No combination of these
will get the phone to turn on so it can charge the battery.

I'm saddened by the fact that a phone that was supposed to be released to
the masses can have such a blatant failing. Not only can it NOT turn on when
the battery has little or no charge, the APM service does not turn the phone
off to prevent this (note: all OTHER phones I have ever used WILL turn off
when the battery gets below some critical level).
On top of this, if I ever expect to have a working phone, I have to disable
the only feature which should extend the battery life (read that as:
OpenMoko has fixed the WSoD problem by replacing it with the BSoD - Black
Screen of Death).

I have looked at the work-arounds, and none of them have worked or are
doable. I refuse to "hardware hack" my phone with an external 4.5V line to
give it the initial charge. I also do not have access to a charger that will
work with this battery. Lastly, I do not have a second battery.

If anyone has any suggestions, I'm open. However, if I'm unable to find a
solution, I I cannot say that I will continue to support or recommend the
OpenMoko platform or the Neo Freerunner phone.
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the support mailing list