[2008.12] ssh instability

Robin Paulson robin.paulson at gmail.com
Thu Jan 8 04:56:41 CET 2009

2009/1/7 Joachim Ott <jo.omsl at googlemail.com>:
> 2009/1/7 Robin Paulson <robin.paulson at gmail.com>
>> i'm having a lot of problems with my ssh connection over usb - it
>> usually takes several attempts to connect, and
>> will hang mid-way through operations very often
>> sometimes un-plugging and re-plugging usb will sort it, sometimes
>> leaving it for a minute or two, or suspending and resuming. sometimes
>> it takes a reboot
>> is this a known problem with the release, or more likely some specific
>> problem here? it worked great with 2008.9, i never had a single
>> problem
> Does "ssh -v root at neo 2>ssh.log" give you a hint, when the error occurs?

yeah, that hangs too, and writes nothing to the log file

the phone itself doesn't hang, and i can run any apps as normal, but
they won't download data - i tested tangogps, and it wouldn't get

so, i tried

sudo ifdown usb0
sudo ifup usb0

and everything worked fine after that, so i figure it's the networking
on the ubuntu side. any suggestions how to fix it?

More information about the support mailing list