GTA01 bricked - WANTED Debug Board in Germany

Joachim Ott jo.omsl at
Thu Jan 8 16:10:42 CET 2009

2009/1/8 Tilman Baumann <tilman at>

> I have just bricked my GTA01, is there anyone on Germany who might be
> willing to reanimate it via JTAG?
> I would send you the unit with a return ticket.
> Paymet for this service could be some bottles of the finest black wood
> forest beer:
> Rothaus Pils
> Waldhaus Pils
> Waldhaus Jubilaeumsdunkel
> How does this sound?
> Here is the story. (Not to repeat!)
> Booting from SD never worked for me. I thought maybe Qi does it better.
> Qi did not, but I lost my DFU-Mode this way.
> (Qi has none and I have no secondary NOR bootloader. Qi Wiki-page was
> written by Frerunenr users.)
> It was clear that I have to go back to uboot as soon as possible because
> I would be screwed the moment my system does not longer boot correctly.
> (happens quickly with only hand full of megs free space)
> I could not find any information on how to write it back with nandwrite.
> Nandwrite has many parameters which I don't understand. And the Internet
> is silent about this.
> My post on the community list stayed unanswered.
> So i just tried it:
> > nandwrite /dev/mtd0 gta01bv4-u-boot.bin
> > Input file is not page aligned
> > Data was only partially written due to error
> > : Success
> Success? Error?
> Well, Error. It does not boot any more!
> nandwrite -o would have probably been the right command... I don't know.
> Could anyone elaborate? This should be documented.

I use "nandwrite -p /dev/mtd..." on the GTA02. "nandwrite -h" should print a
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the support mailing list