Experiences with GTA02 and OM2008.12 (was part of the "Brick" thread)

Gothnet openmoko at nastylittlehorse.net
Tue Jan 20 22:05:42 CET 2009

Craig Woodward wrote:
> Funny you mention that... it's the last on my list, since I've tried most
> of the others but this one has failed to boot after several  attempts.  I
> got  a new uSD card just for this setup to see if thats what's preventing
> the boot.

Two things I found that stop boots on android images I've used are - SD card
partitions and uboot.

If you're using uboot you must alter the uboot environment to be able to use
a larger kernel. The default limit is 2MB. The way I did it was to grab the
uboot env using dfu-util ... basically follow the instructions 
here  but edit the environment.in file to set a kernel partition size of 3
or so MB. There's also a way to do it using the uboot command line but I'm
not familiar with that.

The SD card *must* be formatted with two partitions. The second one *must*
be ext3. The first I usually format as FAT 16, though FAT 32 may work too.
The first partition will appear to android as its SD card, the second will
be used for its data/config store. I don't know what size to recommend, but
it's worked with 2/6GB on my 8GB card.

View this message in context: http://n2.nabble.com/Experiences-with-GTA02-and-OM2008.12-%28was-part-of-the-%22Brick%22-thread%29-tp2172759p2188843.html
Sent from the Openmoko Support mailing list archive at Nabble.com.

More information about the support mailing list