Can't create bug ticket

danek daniel at
Mon Jan 26 14:19:08 CET 2009

I stopped X and gsmd

root at om-gta02:~# /etc/init.d/xserver-nodm stop
Stopping XServer
root at om-gta02:~# /etc/init.d/gsmd stop
Stopping GSM daemon: stopped /usr/sbin/gsmd (pid 1442)

Reset the UART

root at om-gta02:~# stty -F /dev/ttySAC0 sane

Was curious what "sane" would do

root at om-gta02:~# stty -g -F /dev/ttySAC0

Fed it your settings and verified that they took

root at om-gta02:~# stty -F /dev/ttySAC0
root at om-gta02:~# stty -g -F /dev/ttySAC0

Then I wanted to see what it looked like

root at om-gta02:~# stty -a -F /dev/ttySAC0
speed 115200 baud; rows 24; columns 80;
intr = <undef>; quit = <undef>; erase = ^?; kill = ^U; eof = ^D; eol =
<undef>; eol2 = <undef>; start = <undef>; stop = <undef>; susp =
<undef>; rprnt = ^R;
werase = ^W; lnext = ^V; flush = ^O; min = 1; time = 5;
-parenb -parodd cs8 -hupcl -cstopb cread clocal crtscts
ignbrk -brkint -ignpar -parmrk -inpck -istrip -inlcr -igncr -icrnl
-ixon -ixoff -iuclc -ixany -imaxbel
-opost -olcuc -ocrnl -onlcr -onocr -onlret -ofill -ofdel nl0 cr0 tab0
bs0 vt0 ff0
-isig -icanon -iexten -echo -echoe -echok -echonl -noflsh -xcase
-tostop -echoprt -echoctl -echoke

I don't know much about UARTs and serial communication, so really all
I know to look for is what you had mentioned in your bug report, that
on the good FR it said "rows 0; columns 0; line=0" and on the bad one
"rows 24; columns 80;" (as if it were a terminal).

I didn't know what to look for as far as being happy that the UART was
talking OK. I restarted gsmd and X and still couldn't register. I
tried doing the same thing (feeding the UART settings) again with X
stopped and gsmd still running, same thing. I tried it again, and
tried manually conneting to the Calypso instead of using gsmd and
still would not get an AT prompt.

And I still can't open a bug report on Trac.

On Sun, Jan 25, 2009 at 11:19 PM, William Kenworthy (via Nabble)
<ml-user+1677-643196188 at> wrote:
> This is interesting - you have similar uart settings to mine!
> Some things that might be useful:
> minicom, set to 115200,8,n,1 hardware flow control
> Stop X
> stty -F /dev/ttySAC0 sane
> stty -F /dev/ttySAC0
> "1:0:800018b2:0:0:0:7f:15:4:5:1:0:0:0:0:0:12:f:17:16:0:0:0:0:0:0:0:0:0:0:0:0:0:0:0:0"
> (the above is one line - sets the uart)
> Once you are happy the uart is talking ok, try restarting X and see what
> happens.
> What I have been looking at so far is that my uart isnt being
> initialised properly by some software (such as the mux)
> And its already obvious to me that at least two variants of uart configs
> exist (see bug #2215 for the one that works with the mux)
> Hint: be nice if others could check and see what their uart shows if
> they are having connection problems :)
> BillK
> On Sun, 2009-01-25 at 20:04 -0800, danek wrote:
>> I don't have /dev/ttSAC0 ... I'm going to assume ttySAC0 is the same
>> thing.
>> Below I have the output from 2007.2/2008.4, since it's the most recent
>> thing
>> I flashed (to try using GSM manually)
>> If you think another distribution would give different output that would
>> be
>> more useful for your purposes, let me know.
>> My modem did work with FSO (I used milestone 3 briefly, and milestone 4
>> for
>> a little bit longer) when it worked. I never got a chance to try SHR while
>> it was working. I never tried debugging my modem while it was working, so
>> I
>> don't know what parts of its behavior are normal and what parts are new.
>> root at om-gta02:~# stty -a -F /dev/tty
>> /dev/tty      /dev/tty1     /dev/tty3     /dev/ttySAC0  /dev/ttySAC2
>> /dev/tty0     /dev/tty2     /dev/tty4     /dev/ttySAC1
>> root at om-gta02:~# stty -a -F /dev/ttySAC0
>> speed 115200 baud; rows 24; columns 80;
>> intr = ^C; quit = ^\; erase = ^?; kill = ^U; eof = ^D; eol = <undef>;
>> eol2 = <undef>; start = ^Q; stop = ^S; susp = ^Z; rprnt = ^R; werase = ^W;
>> lnext = ^V; flush = ^O; min = 1; time = 0;
>> -parenb -parodd cs8 -hupcl -cstopb cread clocal crtscts
>> -ignbrk -brkint -ignpar -parmrk -inpck -istrip -inlcr -igncr -icrnl -ixon
>> -ixoff -iuclc -ixany -imaxbel
>> -opost -olcuc -ocrnl -onlcr -onocr -onlret -ofill -ofdel nl0 cr0 tab0 bs0
>> vt0
>> ff0
>> -isig -icanon -iexten -echo echoe echok -echonl -noflsh -xcase -tostop
>> -echoprt
>> echoctl echoke
>> root at om-gta02:~# stty -g -F /dev/ttySAC0
>> 0:0:800018b2:a30:3:1c:7f:15:4:0:1:0:11:13:1a:0:12:f:17:16:0:0:0:0:0:0:0:0:0:0:0:0:0:0:0:0
>> William Kenworthy wrote:
>> >
>> > I would appreciate it if you could send me the results of:
>> >
>> > stty -a -F /dev/ttSAC0
>> > stty -g -F /dev/ttSAC0
>> >
>> > Gives me some more data  for my problem
>> >
>> > Tks,
>> > BillK
>> >
> --
> William Kenworthy <billk at ...>
> Home in Perth!
> _______________________________________________
> support mailing list
> support at ...
> ________________________________
> This email is a reply to your post @
> You can reply by email or by visting the link above.

View this message in context:
Sent from the Openmoko Support mailing list archive at

More information about the support mailing list