[om_support] installing TangoGPS

Robin Paulson robin.paulson at gmail.com
Mon Jun 15 05:39:56 CEST 2009

2009/6/15  <fotos at korps-uto.ch>:
> Well, the first time I tried the installation from opkg.org I got the same
> error as with '--force-depends'
>        Configuring libexif
>        Collected errors:
>         * Cannot find package libsqlite3-0.
>         * ERROR: Cannot satisfy the following dependencies for tangogps:
>                 *  gtk+-fastscaling (>= 2.10.14) *  libsqlite3-0 (>= 3.5.6)

yes, you can ignore fastscaling, it's wrong to be there

the correct option for opkg is:


with only one leading hyphen. run opkg without any options, to find
out what different options do

> *
> My original command was:
>        `opkg install libpixman-1-0  libglib-2.0-0
>  http://www.opkg.org/packages/libexif_0.6.17_armv4t.ipk libdbus-glib-1-2
> libdbus-1-3  libcurl4  libcairo2  libsqlite3-0
>  http://www.opkg.org/packages/0_tangogps_0.9.6-r2_armv4t.ipk`

yes, that should work, with -force-depends

> About the thing with the repo, it looks like it has been moved from
> 'http://downloads.openmoko.org/repository/testing/' to
> 'http://downloads.openmoko.org/repository/unstable/'. How ever, there are
> just a few pkg's in the new folder.
> My second atemd has been replacing the word 'testing' with the word
> 'unstable' in the feed's (/etc/opkg/all-feed.conf; /etc/opkg/arch.conf;
> /etc/opkg/armv4-feed.conf; /etc/opkg/armv4t-feed.conf;
> /etc/opkg/om-gta02-feed.conf;). The result was an unusable Phone with a
> compaining dbus.

be careful just changing things like that, it can cause problems

by the way, the part of the e-mail subject which is inside the square
brackets is intended for the operating system you're inquiring about,
not the name of the list, which is already listed in the address

More information about the support mailing list