[SHR-testing] problem with GPS

Abelenda diego.abelenda at gmail.com
Sat Mar 14 07:10:36 CET 2009

On Fri, 13 Mar 2009 19:55:24 +0100
Diego <diego.abelenda at gmail.com> wrote:

> Hi,
> My GPS seems down, even after using the settings to force it ON.
> I first tried TangoGPS, it didn't get any other position than
> "0,0,0,...". 
> Then I tried cat /dev/ttySAC1, nothing... more precisely I get the
> prompt back, cat is not even waiting for something in input, and
> returns 0.
> Then I searched a lot and found about the cli-framework command, I
> tried to see if there was something but nothig to avail...
> I last restarted fso-gpsd and tought it would be intelligent to read
> the logs, found this :
> Mar 13 18:51:44 om-gta02 user.info fso-gpsd[1461]: WARNING: Timeout:
> no gypsy device available Mar 13 18:51:46 om-gta02 user.info
> fso-gpsd[1461]: WARNING: org.freedesktop.Gypsy.Device: Start: Known
> resources are []
> The first warning a lot the second one just once. Any idea ? I have
> none... everything is the default config, so if I missed an important
> step to get it started please tell me ^^
> Regards,
> Diego

Sorry I forgot some info
I am using a GTA02 Revision 0350, no hardware fix for the buzz issue.

I got my GPS working only once, it was months ago on om-2008.8 and
since they I tried from time to time with a lot of distros but nothing
did the trick. I thought that it was my fault, but now many people say
they have no problem with GPS on SHR, so I thought I might give it a

The complete logread output is attached.

Mar 13 18:51:50 is when I started to play with cli-framework .

I tried to connect to gpsd via telnet, (I don't think this might do
anything if cat /dev/ttySAC1 doesn't show anything but well...) here is
what I had in output :


and so on every time the same block.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: gta02-logread.log
Type: text/x-log
Size: 64907 bytes
Desc: not available
Url : http://lists.openmoko.org/pipermail/support/attachments/20090314/033c41d4/attachment-0001.bin 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 198 bytes
Desc: not available
Url : http://lists.openmoko.org/pipermail/support/attachments/20090314/033c41d4/attachment-0001.pgp 

More information about the support mailing list