Help! GSM not working after updating to SHR (was: Moko10)

Joerg Reisenweber joerg at
Sun Mar 15 16:22:56 CET 2009

Am Fr  27. Februar 2009 schrieb Ingvaldur Sigurjonsson:
> Me too is in the same boat.
> After having the Freerunner laying around, untouched, for quite some 
> time I decided to give it a new chance so I started doing some upgrades.
> I also followed the wiki on flashing the GSM  but I never got the 
> "(fluid, version 3) ok".
> Been trying with flashing different kernels/rootfs's to no avail. I cant 
> even get to the phone over USB anymore.  Now the Phone is completely 
> bricked.
> Does anyone know how to unbrick the phone ? A method using debug board 
> maybe ?
> Regards
> - Ingi
> M. K. Pkhetan wrote:
> > Hi everybody,
> > 
> > I really appreciate your help because my phone is not any more a phone!!
> > 
> > the story is that i have updated the GSM firmware to the Moko10 in my 
GTA2Bv5 as described on
> > 
> > I have follow exactly the instructions there on the same proposed FSO, and 
every thing went ok, i even got the message :
> > 
> > (fluid, version 3) ok
> > Checksumming (269 * 8kB = 2152kB):  ok
> > Flash Detect: (0xEC, 0x22A0) Samsung K5A3240CT ok
> > Program: (34 sectors, 267*8k=2136k) (*******************) ok
> > 
> > so every thing seemed ok i even tried the proposed verification :
> > 
> > root at om-gta02:~# cat /dev/ttySAC0 &
> > root at om-gta02:~# echo -en 'AT\r' >/dev/ttySAC0
> > root at om-gta02:~# echo -en 'AT+CGMR\r' >/dev/ttySAC0
> > +CGMR: "HW: GTA, GSM: gsm_ac_gp_fd_pu_em_cph_ds_vc_cal_amd8_ts0-Moko10"
> > kill %1
> > 
> > Well, after that i went back to SHR testing, but i couldn't register to 
the GSM network. i tried FDOM and same thing : no registering
> > 
> > Then i said maybe the firmware is not valid (even that i ckecked the 
md5sum and it was ok) so i tried to downgrade to Moko8 (the gta02bv5 one) but 
i stucked in "Bootloader: (reset target)"
> > 
> > i tried the -oO and -oo. with and without the 'FLUID_FLOWCONTROL=h' and in 
the other season i tried the "s3c24xx-gpio b7=1", "echo 0 
> /sys/bus/platform/devices/neo1973-pm-gsm.0/power_on" and "echo 1 
> /sys/bus/platform/devices/neo1973-pm-gsm.0/power_on" but nothing work i 
can't reflash my GSM anymore

Please notice all this turned out to be a problem of Qi and kernel (here 
SHR-testing) combination, and problem with GSM has been existing prior to 
successful GSM-flashing. 
It's not related to GSM-flashing in the way OP suggests!
Also it's absolutely unnecessary to use devirginator and debug-board to 
recover from this QI+kernel issue leaving GSM serial interface in an unusable 
state. Usual bootloader and/or kernel update following standard dfu-util path 
will suffice, as mentioned by Arne and Al in previous posts.
OP asked for a method to "unbrick" FR and that's the advice Werner gave. 
Nevertheless OP's FR never has been bricked, and usage of devirginator or the 
dynpart/dynenv isn't recommended for a standard procedure.

There's no way to brick FR by flashing GSM.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: This is a digitally signed message part.
Url : 

More information about the support mailing list