SD fails spectacularly and unpredictably when a SIM card is used

Nicola Mfb nicola.mfb at
Fri Mar 27 12:56:02 CET 2009

2009/3/27 Luca Capello <luca at>

> [...]

I am sorry to confirm the problem I had the first time even with
> everything FSO-related switched down and no SIM card in the phone.
> I firstly booted my FR on FSO-MS5.1 and then killed everything
> FSO-related through /etc/init.d/* scripts: xserver-nodm, frameworkd,
> fso-gpsd, fso-monitord, bluetooth.  gsm0710muxd is not running, thus
> AFAIK GSM stuff are disabled.
> I tested two times, again with different results:

I'm not sure if killing the daemon is sufficient, did you try disabling
startup scripts and doing a complete poweroff/poweron cycle?

I'm saying that becouse for about 3 weeks I used the phone with gentoo
testing varius stuff but never emerged fso/zhone, and believe me emerge is
write intensive!. During this period my sd card worked perfectly. One night
I decided to do a tar gz over ssh of my deploy, so booted from SHR testing
from another partition, and after some minutes the sd failed for the first
time in 3 weeks. Every try failed before or after, so I booted from the
flash where I had an old 2008.12 with X disabled *at startup* (so no qtopia,
no fso etc.) and all worked fine again.

P.s. on gentoo I used the same kernel from shr, now I'm using a quite
experimental kernel from paroli om daily builds, but I'm not using phone
related stuff yet.

I think we should update the wiki page about SD, as that reports that
Kingston SD are working well.


-------------- next part --------------
An HTML attachment was scrubbed...

More information about the support mailing list