need sugestions

Iurii yuri at
Tue Nov 24 09:20:41 CET 2009

arne anka wrote:
>> eth0      Link encap:Ethernet  HWaddr 00:14:2a:a9:4d:fb
>>           inet addr:  Bcast:
> here's something wrong already.
> a) eth0 should not have address (for the purpose of easy  
> access to the fr, that is) and
> b) specifically not, when everything is disconnected
>> usb0      Link encap:Ethernet  HWaddr d2:d8:e1:48:cd:a2
>>           UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
>>           RX packets:0 errors:0 dropped:0 overruns:0 frame:0
>>           TX packets:39 errors:0 dropped:0 overruns:0 carrier:0
>>           collisions:0 txqueuelen:1000
>>           RX bytes:0 (0.0 B)  TX bytes:5321 (5.1 KB)
>> usb0:avahi Link encap:Ethernet  HWaddr d2:d8:e1:48:cd:a2
>>           inet addr:  Bcast:   
>> Mask:
>>           UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
> eth0 retains the ip and usb0 does not get any.
> in theory you need the two first commands i posted now (ifdown usb0 and  
> ifconfig), in praxi it wouldn't help much since it most likely clashes  
> with your existing network configuration.
>> here im trying to add a new route : sudo route add-host dev
>> usb0
> hardly probable to work -- usb0 has no ip. you did not do ipdown/ifconfig.
> there are some serious issues with your network configuration (from the  
> point of fr networking at least), which need to be solved first.
> theoretically, you could circumvent them by using another mask and  
> iptables and stuff.
> what's for the moment is mots important, is to figure out why eth0 uses  
> and why it does retain the ip even when disconnected (by  
> which i mean cable being unplugged).
> most lilkly avahi is guilty ...
> please, check the necessary tools for the configured network properties  
> (there should be some tools with graphic user interface available, if  
> everything fails, post the content of /etc/network/interfaces) and figure  
> out, what ip range your router uses.
> furthermore, check if the software on your fr contains an text editor.
> _______________________________________________
> support mailing list
> support at
tnx arne your help was very helpfull i solved the issue ssh now it work 
the problem was actually funny FR stucked i was have to take the battery out
and reconnect it after that it worked ok) 
i still have 1 qustion how can i write files to FR throw the ssh
what are the commands?
tnx again for your time

View this message in context:
Sent from the Openmoko Support mailing list archive at

More information about the support mailing list