Drained battery

William Kenworthy billk at iinet.net.au
Wed Oct 21 10:04:50 CEST 2009

On Thu, 2009-10-22 at 01:21 +1100, Glenn L. McGrath wrote:
> On Tue, 20 Oct 2009 10:39:54 +0530
> max <csy0013 at googlemail.com> wrote:
> > I am attempting to switch on my Freerunner after quite a few months.
> > However, it just doesn't turn on.
> > tried booting with USB power. Nothing worked. Any suggestions other than
> > getting a new battery?  :-)
> I dont think its mentioned in the wiki, but when booting via USB power
> you need to use the USB cable supplied with the openmoko.
> If you have another USB cable it wont supply enough power to allow it
> to boot, USB cables have some sort of id built in which is required to
> allow a higher current than the USB spec specifies to be supplied.
> With the USB cable supplied it should be able to boot without the
> battery.
> Glenn

I think you have it rather mixed up.  These are standard usb cables -
any one with the right connector is ok.  The wall charger, which uses a
usb connector on one end (its NOT a proper usb cable as its for power
only), has a resister connected between two pins to tell the FR that its
capable of supplying 1A.  The usb data cables supplied are standard.

Early hardware (GTA02A5?) - cannot supply enough current to boot from
USB.  The mods were both software (u-boot and then Qi) to stagger the
startup inrush of current as various parts were powered up (hence make
sure you upgrade u-boot or Qi) and add extra capacitance so the voltage
doesnt dip as far power is applied.

I cant point you to a reference for this, but I am sure one of those
involved will jump in (or on me :) if I have got it wrong.


More information about the support mailing list