<div dir="ltr">Hi everybody,<br>
<br>
I experienced something similar yesterday with my Freerunner running a<br>
&nbsp;recent andy+mwester kernel:<br>
<br>
After plugging the turned off phone with about 30% battery left into<br>
the wall charger at night, I woke up to realize the battery had become<br>
completely drained! And in addition, the original battery would not<br>
allow a startup neither with charger nor usb attached, only a spare<br>
nokia and then quick-changing while on USB allowed it to become<br>
recharged again.<br>
<br>
When plugging in the charger, the icon for USB now switches between<br>
shown / not shown in 1s intervals, accompanied by a knock-sound from<br>
the loudspeaker. This happens every time, and looks to me as if the<br>
charger is broken - any other USB device attached to it blinks with<br>
the same frequency, and I cannot measure the 5V but see fluctuations .<br>
<br>
Any idea, or shall I contact my distributor (Pulster) for a spare charger ?<br>
<br>
Stefan<br>
<br><br><div class="gmail_quote">On Sun, Jul 20, 2008 at 7:05 PM, Russell Sears &lt;<a href="mailto:sears@cs.berkeley.edu">sears@cs.berkeley.edu</a>&gt; wrote:<br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
<div class="Ih2E3d">Michael Shiloh wrote:<br>
&gt;<br>
&gt;<br>
&gt; Russell Sears wrote:<br>
&gt;&gt; I&#39;ve started noticing this too. &nbsp;It bit me the night before last, when<br>
&gt;&gt; it was plugged in for 8 hours, but the icon indicated battery status.<br>
&gt;&gt; When I woke up, APM reported the battery was low. (I&#39;ve been regularly<br>
&gt;&gt; running opkg update/upgrade on the factory image).<br>
&gt;&gt;<br>
&gt;&gt; Plug the charger into the phone. &nbsp;Slowly count to 10 or 20. &nbsp;If the<br>
&gt;&gt; icon doesn&#39;t change to have a lightning bolt, unplug the charger from<br>
&gt;&gt; the phone, and repeat.<br>
&gt;<br>
&gt; here&#39;s another thing to try: make sure the phone is really charging,<br>
&gt; either with 500mA or 1000mA (assuming you&#39;re using the wall charger),<br>
&gt; using Andy&#39;s patch that lets you manually set any charge rate:<br>
&gt;<br>
&gt; <a href="http://lists.openmoko.org/pipermail/openmoko-kernel/2008-July/003761.html" target="_blank">http://lists.openmoko.org/pipermail/openmoko-kernel/2008-July/003761.html</a><br>
&gt;<br>
&gt; Let me know the result of this experiment<br>
&gt;<br>
&gt; Michael<br>
<br>
</div>I&#39;m still trying to reproduce the part where it actually runs the<br>
battery down while plugged in, so I haven&#39;t applied the kernel patch.<br>
(Perhaps it was accidentally unplugged or something...) &nbsp;In the meantime:<br>
<br>
What&#39;s the desired policy for charging? &nbsp;Could the charger be shutting<br>
off once the battery is full? &nbsp;I&#39;ve heard that doing this is standard<br>
procedure for Li-Ions, since they don&#39;t like to be continuously topped<br>
off...<br>
<br>
My phone is plugged into the charger right now, and says it&#39;s not<br>
charging. &nbsp;It said it was charging an hour ago, so now its just a<br>
matter of waiting... &nbsp; I&#39;ll disable power management, enable wifi, gps,<br>
etc, and see if that gets it to drain the battery while charging.<br>
<br>
charger_type contains:<br>
<br>
charger 1A mode 1A<br>
<br>
chgstate:<br>
enabled usb_present<br>
<br>
chgcur is empty<br>
<br>
chgmode:<br>
enabled<br>
<br>
apm says:<br>
Off-line, battery status high:<br>
98% (5d+3:01:00)<br>
<br>
** Update **<br>
<br>
I was having some problems with my mail client, so this has been sitting<br>
in my outbox. &nbsp;Anyway, I left the phone on the charger last night, woke<br>
up and it was on with the red and exclamation point in the battery<br>
status icon. &nbsp;I pulled the charger plug out of the phone and reinserted<br>
it, which shut down the phone. &nbsp;I can&#39;t turn it back on, so I&#39;m going to<br>
buy a second battery and/or external charger today... &nbsp;It seems the best<br>
way to reproduce the issue is with a batter that&#39;s not nearly full.<br>
<br>
-Rusty<br>
<div><div></div><div class="Wj3C7c"><br>
<br>
_______________________________________________<br>
support mailing list<br>
<a href="mailto:support@lists.openmoko.org">support@lists.openmoko.org</a><br>
<a href="https://lists.openmoko.org/mailman/listinfo/support" target="_blank">https://lists.openmoko.org/mailman/listinfo/support</a><br>
</div></div></blockquote></div><br></div>