Openmoko Bug #2155: opkg-native do_compile failed

Openmoko Public Trac bugs at
Thu Dec 4 23:02:53 CET 2008

#2155: opkg-native do_compile failed
 Reporter:  manitu   |          Owner:  tick                                                                                                        
     Type:  defect   |         Status:  in_testing                                                                                                  
 Priority:  high     |      Milestone:                                                                                                              
Component:  opkg     |        Version:                                                                                                              
 Severity:  blocker  |       Keywords:  opkg opkg-native do_compile SUSE11.0 compile error free_error_list opkh_cmd.c opkg_cmd opkg_print_error_list
 Haspatch:  1        |      Blockedby:                                                                                                              
Estimated:           |    Patchreview:                                                                                                              
 Blocking:           |   Reproducible:  always                                                                                                      

Comment(by manitu):

 sorry for write back so late, forgot to send the message:

 i tested it all day, once i tried to make update-makefile; make update;
 make setup; make clean-package-opkg-native; make all;
 doesn't working, then same with make image, not working, then with make
 clean-package-opkg, not working

 then i added some empty lines in the file, make clean-package-opkg-native,
 same error, at same line, it didn't moved down, so it didn't notice the

 after that i created a new dir and downloaded makefile there, make setup,
 make image, same error

 i already tried it with 8 processes at same time(like in the tips section)
 and without this change, same error, same line

 i also tried the make om-gta02 thing, just same error^^

 i think only thing i didn't try is to change the gcc version, i already
 tried to install it from the suse dvd, but it was the same version as
 installed, so i have to look how i can compile my own gcc without losing
 some of my x services, because they depend on it

 but the big question, why it didn't notice the changes in the file and
 still showed the error at the old line, what commands i need to type, for
 reloading it(if you know it, i will try to duplicate this free_error_log
 function and write the second one in opkg_cmd.h/c, so it have to be there)

 thanks for the commit of the fix :)

Ticket URL: <> <>
openmoko trac

More information about the buglog mailing list