Openmoko Bug #2185: AUX button makes interrupt storm

Openmoko Public Trac bugs at
Mon Dec 22 01:50:52 CET 2008

#2185: AUX button makes interrupt storm
 Reporter:  vnevoa   |          Owner:  openmoko-devel       
     Type:  defect   |         Status:  new                  
 Priority:  normal   |      Milestone:                       
Component:  unknown  |        Version:  Om2008.9-dev         
 Severity:  normal   |       Keywords:  AUX button interrupts
 Haspatch:  0        |      Blockedby:                       
Estimated:           |    Patchreview:                       
 Blocking:           |   Reproducible:  always               

Comment(by arhuaco):

 >I get the same behaviour under "Hackable:1": 2 interrupts on pressing, 10
 on releasing. But since it is aparently using the same kernel as
 OM2008.12, this still doesn't separate HW from SW.

 It is hardware I think. I tried both new and old kernel. Perhaps something
 happened to the button. I'll try a software fix.

 The pull-down thing did not work for me. This is the code I used for
 testing... I'm sending it in case someone can point out a  mistake...

 +#include <mach/regs-gpio.h>
  static int neo1973kbd_probe(struct platform_device *pdev)
         struct neo1973kbd *neo1973kbd;
 @@ -355,6 +359,8 @@ static int neo1973kbd_probe(struct platform_device


 +       s3c2410_gpio_pullup(S3C2410_GPF6, 0);
         return 0;

 We might have to resort to what they do for neo1973kbd_headphone_irq. I
 think it is a similar case. I will send the URI of a compiled kernel so
 that you can try it out. It will be a new kernel (2.6.28). I think it
 might be easy to port to 2.6.24...

Ticket URL: <> <>
openmoko trac

More information about the buglog mailing list