Openmoko Bug #1612: openmoko-dates doesn't update calendar entry time

Openmoko Public Trac bugs at
Tue Jul 15 15:33:46 CEST 2008

#1612: openmoko-dates doesn't update calendar entry time
 Reporter:  brianwc  |       Owner:  openmoko-devel
     Type:  defect   |      Status:  new           
 Priority:  normal   |   Milestone:  OM-2007.2     
Component:  unknown  |     Version:                
 Severity:  major    |    Keywords:  dates calendar
 Blocking:           |   Blockedby:                
 I'm using FreeRunner, flashed to latest recommended 2007.2 kernel and
 rootfs.  I am currently running the FreeRunner without a SD card.

 I installed openmoko-dates2 and tried to enter a calendar entry.  Besides
 finding the date/time up/down buttons very unintuitive on first use, once
 I understood how to enter dates and times I finally got an entry where the
 start time was off by one hour from what I intended.  So, I went back in
 to edit it, fixed the start time, went back to the "Week starting..." view
 and saw that the start time was still not updated.  I went back and edited
 the start time two additional times, each time with the same result: it
 will not update the start time.

 I also added a second entry, then tried to go back and edit its start time
 and it also will not update. This makes the calendar completely unusable.

 Also, in this process it was particularly frustrating that the dates
 program assumes that an event must last a specified duration and ALSO
 updates the end time when I just wanted to edit the start time.  That is,
 if an entry was 10am-11am and I want to change it to 9:45am-11am, I have
 to make two changes, fighting with the software as I go, because when the
 start time is changed to 9:45, the end time also changes to 10:45, and so
 I have to go change the end time back to 11, and then in the end, it
 doesn't even save any of these changes.

Ticket URL: <> <>
openmoko trac

More information about the buglog mailing list