Openmoko Bug #1656: Bad A2DP performance

Openmoko Public Trac bugs at
Wed Jul 23 02:14:17 CEST 2008

#1656: Bad A2DP performance
 Reporter:  Mercury  |       Owner:  openmoko-devel
     Type:  defect   |      Status:  new           
 Priority:  normal   |   Milestone:                
Component:  unknown  |     Version:                
 Severity:  normal   |    Keywords:                
 Blocking:           |   Blockedby:                
 I tried setting up A2DP.

 First I bonded my freerunner with my headphones using instructions from

 Then I added an entry in asound.conf like this:
 pcm.!default {
   type bluetooth
   device "AA:BB:CC:DD:EE:FF"

 Then I followed some instructions on the openmoko wiki and ran a script
 like this:
 import dbus
 bus = dbus.SystemBus()
 manager = dbus.Interface(bus.get_object('org.bluez', '/org/bluez'),
 conn = manager.ActivateService('audio')
 audio = dbus.Interface(bus.get_object(conn, '/org/bluez/audio'),
 path = audio.CreateDevice('00:15:0E:A0:63:5A')
 sink = dbus.Interface(bus.get_object(conn, path), '')

 It worked, but I got extremely bad performance.  It was so choppy it was
 completely unlistenable.  Maybe 5% of the sound made it to my ears.

 I tried it with another A2DP headset, and I got the same results.

 I don't know if I'm doing something wrong, if there's a bug, if there's  a
 flaw in the freerunner, or if the chip isn't capable of the bandwidth
 needed for this?

Ticket URL: <> <>
openmoko trac

More information about the buglog mailing list