Openmoko Bug #2274: Kernel regression: white screen of death reappeared with 2.6.29

Openmoko Public Trac bugs at
Sun Jul 19 04:03:25 CEST 2009

#2274: Kernel regression: white screen of death reappeared with 2.6.29
 Reporter:  CyrusDreams      |          Owner:  openmoko-kernel          
     Type:  defect           |         Status:  new                      
 Priority:  highest          |      Milestone:  stable-kernel-2009.1     
Component:  System Software  |        Version:  GTA02v5                  
 Severity:  critical         |       Keywords:  WSoD white screen suspend
 Haspatch:  0                |      Blockedby:                           
Estimated:                   |    Patchreview:                           
 Blocking:                   |   Reproducible:                           

Comment(by seven):

 Hi, I have experienced a similar problem.

 Yesterday I flashed the SHR testing distribution with u-boot, and after
 flashing I could boot only from NOR boot until I replaced u-boot with qi.

 Otherwise I kept getting static on the screen and the device unresponsive
 to inputs, and had to plug the battery off to get it working.

 While going into NOR boot and selecting "boot" option was working.

 I used these images: (found in
 testing/images/om-gta02/ )
 rootfs: shr-lite-image-om-gta02.jffs2

 I remember that uname -r returned "2.6.29-r2".

 Today 18 july 2009 I flashed the om2009 and had the same behaviour.

 -first, I updated the GSM firmware as described here:
 -then I flashed the u-boot, kernel and rootfs (i nor-booted between each
 flash) with the images taken from :
   -u-boot: u-boot-
   -rootfs: fso-paroli-image-om-gta02.jffs2 (dated 16-Jun-2009)

 (please note: uname -r still gives 2.6.29-r2)

 Again when I attempted to boot i got static noise and device unresponsive,
 having to pull off the battery. Going into NOR boot menu and selecting the
 "Boot" entry worked.

 Flashing qi ( qi-
 s3c2442-1.0.2+gitr3b8513d8b3d9615ebda605de4bda18371aa3f359.udfu ) solved
 the problem.

 According to /proc/cpuinfo, my hardware is GTA02 and revision 0360.

Ticket URL: <> <>
openmoko trac

More information about the buglog mailing list