r962 - trunk/src/target/u-boot/patches

laforge at sita.openmoko.org laforge at sita.openmoko.org
Mon Feb 12 10:21:20 CET 2007


Author: laforge
Date: 2007-02-12 10:21:19 +0100 (Mon, 12 Feb 2007)
New Revision: 962

Modified:
   trunk/src/target/u-boot/patches/nand-dynamic_partitions.patch
Log:
* rename 'u-boot env' to 'u-boot_env' since mtdparts= doesn't parse spaces in partition names
* rename 'initrd' partition to 'splash' and make it 2MB instead of 4MB
* rename 'gta01-0' to 'neo1973-nand' just like the kernel name (Closes: #173)


Modified: trunk/src/target/u-boot/patches/nand-dynamic_partitions.patch
===================================================================
--- trunk/src/target/u-boot/patches/nand-dynamic_partitions.patch	2007-02-12 09:17:15 UTC (rev 961)
+++ trunk/src/target/u-boot/patches/nand-dynamic_partitions.patch	2007-02-12 09:21:19 UTC (rev 962)
@@ -24,8 +24,8 @@
  }
  
 +#define ARRAY_SIZE(x)           (sizeof(x) / sizeof((x)[0]))
-+static unsigned int part_size[] = { 0x30000, 0x4000, 0x200000, 0x400000, 0x39cc000 };
-+static char *part_names[] = { "u-boot", "u-boot env", "kernel", "initrd", "rootfs" };
++static unsigned int part_size[] = { 0x30000, 0x8000, 0x200000, 0x200000, 0x39cc000 };
++static char *part_names[] = { "u-boot", "u-boot_env", "kernel", "splash", "rootfs" };
 +
 +int nand_create_mtd_dynpart(struct mtd_info *mtd)
 +{
@@ -108,8 +108,8 @@
  
  #define CONFIG_S3C2410_NAND_BBT		1
  
-+#define MTDIDS_DEFAULT	"nand0=gta01-0"
-+#define MTPARTS_DEFAULT	"gta01-0:192k(u-boot),4k(u-boot env),2M(kernel),4M(initrd),-(jffs2)"
++#define MTDIDS_DEFAULT	"nand0=neo1973-nand"
++#define MTPARTS_DEFAULT	"neo1973-nand:192k(u-boot),8k(u-boot_env),2M(kernel),2M(splash),-(jffs2)"
 +
  #endif	/* __CONFIG_H */
 Index: u-boot.git/common/cmd_jffs2.c





More information about the commitlog mailing list