Broken Sim Card Reader?

Harrison Metzger harrisonmetz at
Fri Jul 27 04:06:05 CEST 2007


Thanks for the reply but it dosent work. Clicking that icon also crashes the
bar. I have tried 3 different sim cards that all work in 3 other phones but
on neo keeps tilling me that my sim card is not inserted (CME ERROR 10).


On 7/26/07, Mark Eichin <eichin-openmoko at> wrote:
> "Harrison Metzger" <harrisonmetz at> writes:
> > Dear community,
> >
> > I received my neo today and have been playing around with it a bunch. I
> can
> > get any of the "phone" part of the phone to work. I have been playing
> around
> > with the GSM AT command set and issuing commands to the modem manually
> and
> > from the gsm tool. However I could not register it on the network. I
> looked
> > further into it and I when i do: AT+CNUM it returns CME ERROR 10, and I
> > looked at what that meant in the the GSM proto manual and it means SIM
> card
> > not inserted. The sim card is inserted. Its an AT&T prepaid simcard. I
> have
> > tried it in other phones and it works, ive also tried other working sim
> > cards (from ATT) in the neo and its a no go. I know the SIMs work, so I
> > figure it is the neo. There was talk on IRC about 3.3v sims vs 5v, but I
> > have no idea what to do with that. I'm stuck. I *dont* think I have a
> > defective device, but I can't think of what else it would be.
> I just bought a T-Mobile (US) pay-as-you-go SIM (for hacking with
> until I decide to switch the old 6630 over.)  Like the (ancient
> *OMNIPOINT*) SIM in the other phone, it didn't work the first time.
> Then I tapped the antenna icon with the stylus, got 3 choices - "power
> on gsm antenna", "auto register with network", "power off gsm
> antenna".
> I picked "power on gsm antenna"... and the whole icon bar crashed :-)
> Then I hard powercycled it (hold down power button until the screen
> blanks, no menu comes up because that part is crashed) and when it
> came up, it was talking to the network...
> I know that sounds mystical, but if the pattern works for you, then
> maybe there's something worth diagnosing...
> Note: I'm using the rootfs posted earlier from
> I still haven't gotten sound out of it, but it does make and accept
> calls.
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the community mailing list