Freerunner GPS not working

Ole Kliemann ole-om-community-2008 at
Fri Aug 1 14:00:13 CEST 2008

On Fri, Aug 01, 2008 at 10:23:30AM +0200, Jan Keymeulen wrote:
> Hi,
> I'm unable to get a GPS fix on my Freerunner, S/N 8A8602882. I'm using
> a "Linux om-gta02 2.6.24 #1 PREEMPT Wed Jul 30 11:56:48 CEST 2008"
> kernel with the stock 2007.2 that came with the Freerunner.
> After trying agpsui as descibed in the wiki for about an hour - without any
> satellites seen and trying the instructions given in 
> I still
> don't get squad. Of course, tangogps and the lot don't work either.
> For those who understand NMEA, I'm seeing the following sequence in a
> apparently endless loop:
> $GPRMC,,V,,,,,,,,,,N*53
> $GPVTG,,,,,,,,,N*30
> $GPGGA,,,,,,0,00,99.99,,,,,,*48
> $GPGSA,A,1,,,,,,,,,,,,,99.99,99.99,99.99*30
> $GPGSV,1,1,00*79
> $GPGLL,,,,,,V,N*64
> $GPZDA,,,,,00,00*48
> For as far I can see, the internal antenna connector is seated well.

I have the same problems. Tried with SD removed but makes no difference.
Sometimes when I get a fix with external antenna and unplug it then, the
internal is able to hold the fix; but not always. Internal never gets a
fix on its own. 

I had the FR open once. I think the internal connector sits fast. I
haven't tried to unplug and replug it because the cable that runs from
the plug to the antenna scared me. At the point where it is soldered to
the antenna it is so thin and looked so fragile and worn off, I was
afraid it would fall off any second.

But I am not experienced enough to say whether this is normal.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: not available
Url : 

More information about the community mailing list