strange problem with Intenso 4GB SDHC card

Gianluigi pulciux at
Fri Aug 8 08:51:04 CEST 2008

Alle 01:16, sabato 26 luglio 2008, Thomas B. ha scritto:
> On Fri, Jul 25, 2008 at 11:44:37PM +0200, AVee wrote:
> > On Friday 25 July 2008 10:54, arne anka wrote:
> > > i got a 4 gig card too (can't say if from intenso, have to check the
> > > wrapping).
> > > my card's boot sector is not erased but -- after a resume the card is
> > > mounted wrongly!
> > >
> > > fstab says as mountpoint /media/card and after booting that's where the
> > > card is.
> > > after suspend/resume the card (often) is mounted to /media/mmcblk1p1
> > > instead -- thus every attempt to read from or write to the sd card goes
> > > to the built-in memory instead.
> >
> > I can confirm seeing the same behaviour with a Sandisk 8GB card...
> Me too (also Sandisk 8GB). It bit me while running Qtopia from SD card:
> Upon resuming the system crashed, probably because the rootfs was
> gone...
> I could reproduce this after having booted from flash. dmesg log of the
> suspend/resume cycle is attached.
> Regards,
> Thomas

Any fix for this problem?

I've made many test with a 4G SD.
If use it for boot qtopia from vfat and ext2 partions it work fine. Slowly but 

If I start system from 2007.2 in flash the mounted SD partitions give me many 

Sometime was mounted 1st partion, sometime all of than.
I've tried to access it in reading and writing and frequently I get I/O errors 
in dmesg.

On time was loose partition table (in suspend/resume session).

I've tried many partitions schemas (mixed FAT and ext2) but always I/O errors 

I've reformatted in a unique partition with FAT and I've filled in it about 
1GB of maps for tangogps from my PC.

The partition was mounted in /media/card and when tangogps start to read from 
SD some file was read good and many other not.
The screen become full noised when SD is reading and get I/O errors.
After the read go to end the screen come back showing fine.

The 4GB SD with my PC work fine, no I/O errors.
The 512M SD in FR package always work very well.

The 4GB SD is a Apacer Micro SDHC 4GB Class 6.

The sooner our happiness together begins, the longer it will last.
		-- Miramanee, "The Paradise Syndrome", stardate 4842.6

More information about the community mailing list