can't connect to internet after ASU upgrade

Dimitri spam2 at
Fri Aug 8 19:41:15 CEST 2008

Daniel Benoy wrote:
> have you checked the default route?  The 'gateway' line in
> /etc/network/interfaces should be under usb0, and you should see it when
> you run 'ip route show' (default via ADDRESS dev usb0).

I think it's set up properly. I get the following when I run: ip route show dev usb0  src
default via dev usb0

And, I get the following when I run: cat /etc/network/interfaces

# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)

# The loopback interface
auto lo
iface lo inet loopback

# Wireless interfaces
iface wlan0 inet dhcp
wireless_mode managed
wireless_essid any
iface atml0 inet dhcp

# Wired or wireless interfaces
iface eth0 inet dhcp
iface eth1 inet dhcp

# Ethernet/RNDIS gadget (g_ether)
# ... or on host side, usbnet and random hwaddr
auto usb0
iface usb0 inet static

# Bluetooth networking
iface bnep0 inet dhcp

Daniel Benoy wrote:
> If it's a freerunner, you may also want to consider getting it on a
> wireless network for simplicity's sake.

Under settings, it says "WiFi" but doesn't say "on" OR "off". It's just
blank. And if I click it, it says "WiFi       unknown".

Anyway... one problem at a time, right? :)

View this message in context:
Sent from the Openmoko Community mailing list archive at

More information about the community mailing list